Hoe goed is jouw website?

Overgaan naar WordPress 5.0 ja of nee?

Nog een paar daagjes en dan komt WordPress versie 5.0 uit. In deze nieuwe WordPress versie zitten een aantal nieuwe features die grotere impact kunnen hoe WordPress nu wordt gebruikt. De afgelopen tijd hebben wij daarom WordPress 5.0 uitgetest. Voor mensen die niet kunnen wachten om over te gaan hieronder staan een aantal belangrijke zaken die je moet weten voordat je upgrade naar de laatste WordPress versie.

De nieuwe editor Gutenberg

In de nieuwe update wordt door WordPress de nieuwe editor “Gutenberg” geïntroduceerd. Deze editor werkt totaal anders dan de huidige WordPress editor en is in zijn geheel herschreven (zie een vorig artikel over de  Gutenberg editor). Wanneer de website wordt geüpgrade  zal de website in eerste instantie  geen fouten geven.

Page builders in Gutenberg

Een page builder is een plugin waarmee je door middel van drag en drop gemakkelijk je websitepagina’s kunt samenstellen zonder kennis te hebben van HTML of  WordPress shortcodes. Voorbeelden van page builder zijn  Elementor, WPBakery, SiteOrigin en Beaver Builder. Maak je in de site gebruik van page builders, dan kunnen sommigen page builders niet meer correct werken omdat deze afhankelijk zijn van de oude classic editor.  Zorg dus dat je eerst uitzoekt of jouw page builder in Gutenberg nog blijft werken.

De plugin Disable Gutenberg

Blijkt dat jouw page builder Gutenberg niet goed ondersteunt of vind je de nieuwe editor niet fijn werken, dan kun je de classic editor toch nog blijven gebruiken in WordPress 5.  Met de “Classic Editor” plugin wordt Gutenberg uitgeschakeld en kun je net zoals in de huidige WordPress versie teksten bewerken.

WooCommerce

Heb je een WooCommerce webshop let dan op. Zorg dat je WooCommerce versie in ieder geval 3.5.1 is of hoger. Versie 3.5.1 is namelijk gemaakt om te werken met WordPress 5.0. In het submenu “status”  van WooCommerce kun je zien welke versie van WooCommerce je nu draait.

De WordPress gemeenschap over WordPress 5.0

Er is momenteel veel discussie binnen de WordPress gemeenschap of WordPress 5.0 wel deze maand uit moet komen. Met name het grote aantal openstaande tickets en bugs die doorgeschoven zijn naar een latere versie baart velen (en ons ook) zorgen. Door het doorschuiven van belangrijke features is de kans namelijk groot dat veel plugin-bouwers hun code later weer moeten herschrijven voor WordPress 5.0. En op dit extra werk zitten ze uiteraard niet te wachten.

Upgraden wel of niet?

Upgraden naar deze laatste versie is een grote stap en kan veel impact hebben op jouw website. Mede door de vele onderzekerheden is daarom ons advies dan ook om even te wachten met de upgrade en in een latere (stabielere) versie naar 5.0 te upgraden.

Kun je niet wachten om over te gaan naar WordPress 5.0 let dan in ieder geval op de volgende zaken:

  • Zorg dat al je plugins zijn geupdate naar de laatste versie
  • Controleer of alle plugins WordPress 5.0 ondersteunen
  • Test eerst de website uit in een testomgeving voordat je gaat upgraden
  • Zorg dat je backups hebt in het geval dat er onverhoopt iets mis gaat
  • Ga je over op de Gutenberg editor, lees dan hier de documentatie over Gutenberg
Deel dit verhaal:
Kevin Hulzebos

Geschreven door:

Kevin Hulzebos

Zoeken

Hoe goed is jouw WordPress website?

Wil je weten hoe goed jouw website presteert op het gebied van SEO, snelheid en gebruiksvriendelijkheid? Vraag dan bij ons een website analyse aan.

Ik wil een website analyse